VLAN通信

发布于:2022-11-09 ⋅ 阅读:(6) ⋅ 点赞:(0) ⋅ 评论:(0)

1.VLAN之间有几种通信方法?

有三种通信方法

  • 二层交换机+一台路由器实现VLAN间通信(多臂路由)
  • 单臂路由的方式实现VLAN间通信
  • 现网中实际运用vlanif逻辑接口来实现VLAN之间通信(三层交换)

2.三层交换机的工作原理?

  • 使用三层交换技术实现不同vlan之间的通信
  • 三层交换 = 二层交换 + 三层转发
  • 原理:当三层设备接收到一个数据帧,会拆除源数据帧,重新封装新的源MAC地址和目标MAC地址,并且因为帧头部的信息发生变化,最后的帧校验CRC也应当随之改变。
  • 在这个数据流中的多个数据包,其中只有第一个数据包是由三层交换的三层引擎来处理的,处理方式是软件方式,与路由器相同,三层引擎获取了新的2层封装信息后,路由这个数据包。

3.三层交换机能否取代路由器,为什么?

三层交换机不能取代路由器。

三层交换机不能完全替代路由器的原因:

路由器可以实现一种网络的连接;路由器一般情况下路由性能比三层交换机强(CPU、内存);路由器能实现nat,一般交换机没有NAT功能。

三层交换机和路由器的区别

<1> 主要功能不同

虽然三层交换机与路由器都具有路由功能,但不能因此而把它们等同起来,正如现在许多网络设备同时具备多种传统网络设备功能一样,就如现在有许多宽带路由器不仅具有路由功能,还提供了交换机端口、硬件防火墙功能,但不能把它与交换机或者防火墙等同起来一样。因为这些路由器的主要功能还是路由功能,其它功能只不过是其附加功能,其目的是使设备适用面更广、使其更加实用。这里的三层交换机也一样,它仍是交换机产品,只不过它是具备了一些基本的路由功能的交换机,它的主要功能仍是数据交换。也就是说它同时具备了数据交换和路由由发两种功能,但其主要功能还是数据交换;而路由器仅具有路由转发这一种主要功能。

<2> 主要适用的环境不同

三层交换机的路由功能通常比较简单,因为它所面对的主要是简单的局域网连接。正因如此,三层交换机的路由功能通常比较简单,路由路径远没有路由器那么复杂。它用在局域网中的主要用途还是提供快速数据交换功能,满足局域网数据交换频繁的应用特点。

而路由器则不同,它的设计初哀就是为了满足不同类型的网络连接,虽然也适用于局域网之间的连接,但它的路由功能更多的体现在不同类型网络之间的互联上,如局域网与广域网之间的连接、不同协议的网络之间的连接等,所以路由器主要是用于不同类型的网络之间。它最主要的功能就是路由转发,解决好各种复杂路由路径网络的连接就是它的最终目的,所以路由器的路由功能通常非常强大,不仅适用于同种协议的局域网间,更适用于不同协议的局域网与广域网间。它的优势在于选择最佳路由、负荷分担、链路备份及和其他网络进行路由信息的交换等等路由器所具有功能。为了与各种类型的网络连接,路由器的接口类型非常丰富,而三层交换机则一般仅同类型的局域网接口,非常简单。

<3> 性能体验不同

从技术上讲,路由器和三层交换机在数据包交换操作上存在着明显区别。路由器一般由基于微处理器的软件路由引擎执行数据包交换,而三层交换机通过硬件执行数据包交换。三层交换机在对第一个数据流进行路由后,它将会产生一个MAC地址与IP地址的映射表,当同样的数据流再次通过时,将根据此表直接从二层通过而不是再次路由,从而消除了路由器进行路由选择而造成网络的延迟,提高了数据包转发的效率。同时,三层交换机的路由查找是针对数据流的,它利用缓存技术,很容易利用ASIC技术来实现,因此,可以大大节约成本,并实现快速转发。而路由器的转发采用最长匹配的方式,实现复杂,通常使用软件来实现,转发效率较低。

正因如此,从整体性能上比较的话,三层交换机的性能要远优于路由器,非常适用于数据交换频繁的局域网中;而路由器虽然路由功能非常强大,但它的数据包转发效率远低于三层交换机,更适合于数据交换不是很频繁的不同类型网络的互联,如局域网与互联网的互联。如果把路由器,特别是高档路由器用于局域网中,则在相当大程度上是一种浪费(就其强大的路由功能而言),而且还不能很好地满足局域网通信性能需求,影响子网间的正常通信。

综上所述,三层交换机与路由器之间还是存在着非常大的本质区别的。无论从哪方面来说,在局域网中进行多子网连接,最好还选用三层交换机,特别是在不同子网数据交换频繁的环境中。一方面可以确保子网间的通信性能需求,另一方面省去了另外购买交换机的投资。当然,如果子网间的通信不是很频繁,采用路由器也无可厚非,也可达到子网安全隔离相互通信的目的。具体要根据实际需求来定。

4.简单说明生成树的工作原理

工作原理:在任意一交换机中如果到达根网桥有两条或者两条以上的链路,生成树协议都根据算法仅仅保留一条,将其他切断,从而保证任意两个交换机之间只有一条单一的活动链路。 

5.交换机组网为什么会产生环路?

原因:以太网交换网络中为了进行链路备份,提高网络可靠性,通常会使用冗余链路。但是使用冗余链路会在交换网络上产生环路,引发广播风暴以及MAC地址表不稳定等故障现象,从而导致用户通信质量较差,甚至通信中断。为了解决此类问题,交换机在互连时一般都会使用冗余链路来实现备份。冗余链路虽然增强了网络的可靠性,但是也会产生环路,而环路会带来一系列的问题,继而导致通信质量下降和通信业务中断等问题。

6.交换机组网产生的环路会导致哪些问题?

环路导致的现象:形成广播风暴

  • 交换机接口的带宽资源被迅速消耗
  • 交换机的转发资源也被快速消耗殆尽
  • 交换机的MAC地址表出现“飘移”(MAC地址的反复修改接口)

7.园区网组网两个基本思路是什么?

园区网组网的两个基本思路:模块化和层次化

8.将下列交换机配置的园区网形成通路

IP地址规划:

(1)首先将接入层的交换机配置到PC机的接口划入VLAN

  • VLAN 2
[sw4]vlan 2---创建VLAN
[sw4-vlan2]q
[sw4]int g0/0/2
[sw4-GigabitEthernet0/0/2]port link-type access 
[sw4-GigabitEthernet0/0/2]port default vlan 2---接口划入VLAN
[sw4]int g0/0/3
[sw4-GigabitEthernet0/0/3]port link-type access 
[sw4-GigabitEthernet0/0/3]port default vlan 2
[sw4]int g0/0/1
[sw4-GigabitEthernet0/0/1]port link-type trunk 
[sw4-GigabitEthernet0/0/1]port trunk allow-pass vlan 2
[sw4-GigabitEthernet0/0/1]undo port trunk allow-pass vlan 1---由于VLAN1是默认存在,为了防止出现不必要的问题,我们在每个接口上都不能让VLAN1的流量通过。
  • VLAN 3
[sw5]vlan 3
[sw5-vlan3]q
[sw5]int g0/0/2
[sw5-GigabitEthernet0/0/2]port link-type access 
[sw5-GigabitEthernet0/0/2]port default vlan 3
[sw5]int g0/0/3
[sw5-GigabitEthernet0/0/3]port link-type access 	
[sw5-GigabitEthernet0/0/3]port default vlan 3
[sw5]int g0/0/1
[sw5-GigabitEthernet0/0/1]port link-type trunk 
[sw5-GigabitEthernet0/0/1]port trunk allow-pass vlan 3
[sw5-GigabitEthernet0/0/1]undo port trunk allow-pass vlan 1
  • VLAN 200  210
[sw6]vlan batch 200 210
[sw6]int g0/0/2
[sw6-GigabitEthernet0/0/2]port link-type access 
[sw6-GigabitEthernet0/0/2]port default vlan 200
[sw6]int g0/0/3
[sw6-GigabitEthernet0/0/3]port link-type access 
[sw6-GigabitEthernet0/0/3]port default vlan 210
[sw6]int g0/0/1
[sw6-GigabitEthernet0/0/1]port link-type trunk 
[sw6-GigabitEthernet0/0/1]port trunk allow-pass vlan 200 210
[sw6-GigabitEthernet0/0/1]undo port trunk allow-pass vlan 1

(2)汇聚层和接入层相连,创建VLANIF接口

  • SW2 
[sw2]vlan batch 2 3---创建VLAN
[sw2]int vlan 2
[sw2-Vlanif2]ip add 10.1.2.1 24---创建VLANIF接口,为接口配置IP地址
[sw2]int vlan 3
[sw2-Vlanif3]ip add 10.1.3.1 24
[sw2]int g0/0/2
[sw2-GigabitEthernet0/0/2]port link-type trunk 
[sw2-GigabitEthernet0/0/2]port trunk allow-pass vlan 2---允许VLAN2的流量通过
[sw2-GigabitEthernet0/0/2]undo port trunk allow-pass vlan 1
[sw2]int g0/0/3
[sw2-GigabitEthernet0/0/3]port link-type trunk 
[sw2-GigabitEthernet0/0/3]port trunk allow-pass vlan 3
[sw2-GigabitEthernet0/0/3]undo port trunk allow-pass  vlan 1
[sw2]dhcp enable---开启DHCP服务
[sw2]int vlan 2
[sw2-Vlanif2]dhcp select interface---自动为PC端分配IP地址
[sw2]int vlan 3
[sw2-Vlanif3]dhcp select interface 
  • SW3
[sw3]vlan batch 200 210
[sw3]int vlan 200
[sw3-Vlanif200]ip add 10.1.200.1 24
[sw3]int vlan 210
[sw3-Vlanif210]ip add 10.1.210.1 24
[sw3]int g0/0/2
[sw3-GigabitEthernet0/0/2]port link-type trunk 
[sw3-GigabitEthernet0/0/2]port trunk allow-pass vlan 200 210
[sw3-GigabitEthernet0/0/2]undo port trunk allow-pass vlan 1
[sw3]dhcp enable 
[sw3]int vlan 200	
[sw3-Vlanif200]dhcp select interface 
[sw3]int vlan 210
[sw3-Vlanif210]dhcp select interface 

(3)将汇聚层和核心层相连

  • SW2
[sw2]vlan 100---创建VLAN100
[sw2-vlan100]q
[sw2]int vlan 100
[sw2-Vlanif100]ip add 10.1.100.1 24---为VLAN配置IP地址
[sw2]int g0/0/1
[sw2-GigabitEthernet0/0/1]port link-type trunk 
[sw2-GigabitEthernet0/0/1]port trunk allow-pass vlan 100---允许VLAN100的流量通过
[sw2-GigabitEthernet0/0/1]undo port trunk allow-pass vlan 1
  • SW3
[sw3]vlan 1000
[sw3-vlan1000]q
[sw3]int vlan 1000
[sw3-Vlanif1000]ip add 10.1.20.1 24
[sw3]int g0/0/1
[sw3-GigabitEthernet0/0/1]port link-type trunk 
[sw3-GigabitEthernet0/0/1]port trunk allow-pass vlan 1000
[sw3-GigabitEthernet0/0/1]undo port trunk allow-pass vlan 1

(4)在核心层创建VLANIF接口。为AR1配置IP地址

  • SW1
[sw1]vlan batch 100 1000
[sw1]int vlan 1000
[sw1-Vlanif1000]ip add 10.1.20.2 24
[sw1]int g0/0/2
[sw1-GigabitEthernet0/0/2]port link-type trunk 
[sw1-GigabitEthernet0/0/2]port trunk allow-pass vlan 100
[sw1-GigabitEthernet0/0/2]undo port trunk allow-pass vlan 1
[sw1]int vlan 100
[sw1-Vlanif100]ip add 10.1.100.2 24
[sw1]int g0/0/3
[sw1-GigabitEthernet0/0/3]port link-type trunk 	
[sw1-GigabitEthernet0/0/3]port trunk allow-pass vlan 1000
[sw1-GigabitEthernet0/0/3]undo port trunk allow-pass vlan 1
[sw1]vlan 2000
[sw1-vlan2000]q
[sw1]int vlan 2000---创建VLANIF接口和路由器相连
[sw1-Vlanif2000]ip add 10.1.30.1 24
[sw1]int g0/0/1
[sw1-GigabitEthernet0/0/1]port link-type access---为了保证路由的唯一性,我们在这里使用access接口
[sw1-GigabitEthernet0/0/1]port default vlan 2000
  • AR1(为其进行IP地址的配置)
[r1]int g0/0/0
[r1-GigabitEthernet0/0/0]ip add 10.1.30.2 24
[r1]int lo0
[r1-LoopBack0]ip add 10.1.50.1 32---建立环路,方便后续测试

(5)为了保证路由可达,这里我们进行OSPF宣告

[r1]ospf 1 router-id 1.1.1.1
[r1-ospf-1]a 0	
[r1-ospf-1-area-0.0.0.0]network 10.1.30.0 0.0.0.255
[r1-ospf-1-area-0.0.0.0]network 10.1.50.1 0.0.0.0
[sw1]ospf 1 router-id 5.5.5.5
[sw1-ospf-1]a 0
[sw1-ospf-1-area-0.0.0.0]network 10.1.30.0 0.0.0.255
[sw1-ospf-1]a 1
[sw1-ospf-1-area-0.0.0.1]network 10.1.100.0 0.0.0.255
[sw1-ospf-1]a 2	
[sw1-ospf-1-area-0.0.0.2]network 10.1.20.0 0.0.0.255
[sw2]ospf 1 router-id 2.2.2.2
[sw2-ospf-1]a 1
[sw2-ospf-1-area-0.0.0.1]network 10.1.100.0 0.0.0.255
[sw2-ospf-1-area-0.0.0.1]network 10.1.2.0 0.0.0.255
[sw2-ospf-1-area-0.0.0.1]network 10.1.3.0 0.0.0.255
[sw3]ospf 1 router-id 3.3.3.3
[sw3-ospf-1]a 2
[sw3-ospf-1-area-0.0.0.2]network 10.1.20.0 0.0.0.255
[sw3-ospf-1-area-0.0.0.2]network 10.1.200.0 0.0.0.255
[sw3-ospf-1-area-0.0.0.2]network 10.1.210.0 0.0.0.255

测试OSPF建邻情况

(6)查看并测试

将PC端调剂为通过DHCP自动获取IP地址

查看IP地址获取情况






测试能否形成通路



(7)优化

<1> 沉默接口,将SW2和SW3的网关接口沉默,网关接口不需要发送hello占用带宽

[sw2]ospf
[sw2-ospf-1]silent-interface Vlanif 2
[sw2-ospf-1]silent-interface Vlanif 3
[sw3]ospf
[sw3-ospf-1]silent-interface Vlanif 200
[sw3-ospf-1]silent-interface Vlanif 210

<2> 在此处园区网的多路网络中,每个网段只有两个接口互相对应,而多路网络势必会进行DR和BDR的选举,为了不浪费时间,我们将此处网络类型更改为点到点

[sw2]int vlan 100	
[sw2-Vlanif100]ospf network-type p2p
[sw3]int vlan 1000
[sw3-Vlanif1000]ospf network-type p2p
[r1]int g0/0/0	
[r1-GigabitEthernet0/0/0]ospf network-type p2p
[sw1]int vlan 1000
[sw1-Vlanif1000]ospf network-type p2p
[sw1]int vlan 100
[sw1-Vlanif100]ospf network-type p2p
[sw1]int vlan 2000
[sw1-Vlanif1000]ospf network-type p2p

<3> 将区域1和区域2配置成为STUB(末梢区域),这个区域将拒绝学习4,5类的LSA。同时将自动生成一条指向骨干区域的3类缺省。

[sw2]ospf 1
[sw2-ospf-1]a 1
[sw2-ospf-1-area-0.0.0.1]stub
[sw3]ospf
[sw3-ospf-1]a 2
[sw3-ospf-1-area-0.0.0.2]stub
[sw1-ospf-1]a 1	
[sw1-ospf-1-area-0.0.0.1]stub no-summary 
[sw1-ospf-1]a 2
[sw1-ospf-1-area-0.0.0.2]stub no-summary

优化不影响各个网段之间的通信,我们在此测试一下