三层交换技术

发布于:2022-11-09 ⋅ 阅读:(7) ⋅ 点赞:(0) ⋅ 评论:(0)

一、实验环境

系统版本 Windows 10 专业工作站版 (版本号22H2)
ENSP版本 1.3.00.100
交换机版本 S5700/S3700

 二、实验拓扑

三、实验要求

        通过给路由器添加子接口使不同网段的PC互联互通;

        IP地址配置情况:

PC1 本机:192.168.10.1/24 网关:192.168.10.254/24
PC2 本机:192.168.20.1/24 网关:192.168.20.254/24
PC3 本机:192.168.30.1/24 网关:192.168.30.254/24
VLAN10 192.168.10.254/24
VLAN20 192.168.20.254/24
VLAN30 192.168.30.254/24


四、实验设备基础配置

PC1:

PC2:

PC3:

 五、交换机和路由器配置

二层交换机:

<SW1>system-view

[SW1]vlan batch 10 20 30                                                           //创建VLAN10和20

[SW1]interface Ethernet 0/0/1                                                     //进入端口

[SW1-GigabitEthernet0/0/1]port link-type access                       //端口模式改成access

[SW1-GigabitEthernet0/0/1]port default vlan 10                         //给端口划分VLAN

[SW1]interface Ethernet 0/0/2                                                     //进入端口

[SW1-GigabitEthernet0/0/2]port link-type access                       //端口模式改成access

[SW1-GigabitEthernet0/0/2]port default vlan 20                         //给端口划分VLAN

[SW1]interface Ethernet 0/0/3                                                     //进入端口

[SW1-GigabitEthernet0/0/3]port link-type access                       //端口模式改成access

[SW1-GigabitEthernet0/0/3]port default vlan 30                         //给端口划分VLAN

[SW1]interface Ethernet 0/0/20

[SW1-Ethernet0/0/20]port link-type trunk                                   //端口模式改为trunk

[SW1-Ethernet0/0/20]port trunk allow-pass vlan all                   //允许所有VLAN通过

三层交换机:

<SW2>system-view

[SW2]vlan batch 10 20 30

[SW2]interface GigabitEthernet 0/0/20

[SW2-GigabitEthernet0/0/20]port link-type trunk

[SW2-GigabitEthernet0/0/20]port trunk allow-pass vlan all

[SW2]interface Vlanif 10

[SW2-Vlanif10]ip add 192.168.10.254 24

[SW2]interface Vlanif 20

[SW2-Vlanif20]ip add 192.168.20.254 24

[SW2]interface Vlanif 30

[SW2-Vlanif30]ip add 192.168.30.254 24

六、检测设备连通性

PC1 PING PC2/PC3


总结

        随着互联网的发展,局域网和广域网技术得到了广泛的推广和应用。数据交换技术从简单的电路交换发展到二层交换,从二层交换又逐渐发展到今天较成熟的三层交换。 三层交换技术就是二层交换技术+三层转发技术。它解决了局域网中网段划分之后,网段中子网必须依赖路由器进行管理的局面,解决了传统路由器低速、复杂所造成的网络瓶颈问题。