思科网络部署实验

发布于:2022-11-09 ⋅ 阅读:(9) ⋅ 点赞:(0) ⋅ 评论:(0)

作者介绍:

作者:小刘在C站

每天分享课堂笔记,一起努力,共赴美好人生!

夕阳下,是最美的绽放。

今天带个大家一个实验,为网络篇的综合实验,有能力的可以试一试不会的可以私信小刘。

 

配置三层  热备    ospf 和 rip 以及他们之间的重分发等将内网 全通

一.三层交换机配置

三层交换机一

ip routing

int f0/1

no sw

ip add 10.0.0.6  255.255.255.0

no sh

vlan 10

vlan 20

int range f0/2 -4

sw tr en do

sw mo tr

interface Vlan10

 ip address 192.168.10.1 255.255.255.0

 standby version 2

 standby 10 ip 192.168.10.254

 standby 10 priority 200

 standby 10 preempt

 standby 10 track FastEthernet0/1

interface Vlan20

 ip address 192.168.20.1 255.255.255.0

 standby version 2

 standby 20 ip 192.168.20.254

 standby 20 priority 195

 standby 20 preempt

router ospf 1

 router-id 10.10.10.10

 network 10.0.0.4 0.0.0.3 area 10

 network 192.168.10.0 0.0.0.255 area 10

 network 192.168.20.0 0.0.0.255 area 10

三层交换机二

ip routing

int f0/1

no sw

ip add 10.0.0.10  255.255.255.0

no sh

vlan 10

vlan 20

int range f0/2 -4

sw tr en do

sw mo tr

interface Vlan10

 ip address 192.168.10.2 255.255.255.0

 standby 10 ip 192.168.10.254

 standby 10 priority 195

 standby 10 preempt

interface Vlan20

 ip address 192.168.20.1 255.255.255.0

 standby 20 ip 192.168.20.254

 standby 20 priority 200

 standby 20 preempt

 standby 20 track FastEthernet0/1

router ospf 1

 router-id 20.20.20.20

 network 10.0.0.8 0.0.0.3 area 10

 network 192.168.10.0 0.0.0.255 area 10

 network 192.168.20.0 0.0.0.255 area 10

两个二层交换机的配置

Switch>en

Switch#conf t

Switch(config)#vlan 10

Switch(config-vlan)#vlan 20

Switch(config-vlan)#exit

Switch(config)#int range f0/1 -2

Switch(config-if-range)#sw mo tr

Switch(config-if-range)#exit

Switch(config)#int f0/3

Switch(config-if)#sw ac vlan 10

Switch(config-if)#int f0/4

Switch(config-if)#sw ac vlan 20

router 2 路由器配置

Router>en

Router#conf t

Router(config)#int f0/1

Router(config-if)#ip add 10.0.0.5 255.255.255.252

Router(config-if)#no sh

Router(config-if)#int f1/0

Router(config-if)#ip add 10.0.0.9 255.255.255.252

Router(config-if)#no sh

Router(config)#int f0/0

Router(config-if)#ip add 10.0.0.1 255.255.255.252

Router(config-if)#no sh

Router(config-if)#exit

Router(config)#router ospf 1

Router(config-router)#router-id 2.2.2.2

Router(config-router)#network 10.0.0.0 0.0.0.3  area 0

Router(config-router)#network 10.0.0.4 0.0.0.3  area 10

Router(config-router)#network 10.0.0.8 0.0.0.3  area 10

router 1 路由器的接口和动态路由配置

Router>en

Router#conf t

Router(config)#int f0/0

Router(config-if)#ip add 61.129.62.130 255.255.255.0

Router(config-if)#no sh

Router(config-if)#int f0/1

Router(config-if)#ip add 10.0.0.2 255.255.255.252

Router(config-if)#no sh

Router(config-if)#int f1/0

Router(config-if)#ip add 10.0.0.13 255.255.255.252

Router(config-if)#no sh

Router(config-if)#exit

Router(config)#router ospf 1

Router(config-router)#router-id 1.1.1.1

Router(config-router)#network 10.0.0.0 0.0.0.3 area 0

Router(config-router)#network 10.0.0.12 0.0.0.3 area 2

Router(config-router)#default-information originate

Router(config-router)#exit

Router(config)#ip route 0.0.0.0 0.0.0.0 61.129.62.131

Router 3 路由器的配置

Router>en

Router#conf t

Router(config)#int f0/0

Router(config-if)#ip add 10.0.0.14 255.255.255.252

Router(config-if)#no sh

Router(config-if)#int f0/1

Router(config-if)#ip add 192.168.1.1 255.255.255.0

Router(config-if)#no sh

Router(config-if)#int f1/0

Router(config-if)#ip add 172.16.0.1 255.255.255.0

Router(config-if)#no sh

Router(config-if)#exit

Router(config)#router ospf 1

Router(config-router)#router-id 3.3.3.3

Router(config-router)#network 10.0.0.12 0.0.0.3 area 2

Router(config-router)#redistribute rip subnets

Router(config-router)#exit

Router(config)#router rip

Router(config-router)#version 2

Router(config-router)#no auto-summary

Router(config-router)#network 192.168.1.0

Router(config-router)#network 172.16.0.0

Router(config-router)#redistribute ospf 1  metric 10

router 4 路由器配置

Router(config)#int f0/0

Router(config-if)#ip add 192.168.1.2 255.255.255.0

Router(config-if)#no sh

Router(config-if)#int f0/1

Router(config-if)#ip add 192.168.100.1 255.255.255.0

Router(config-if)#no sh

Router(config-if)#exit

Router(config)#router rip

Router(config-router)#version 2

Router(config-router)#no auto-summary

Router(config-router)#network 192.168.100.0

Router(config-router)#network 192.168.1.0

Router(config-router)#exit

ISP 路由器配置

Router(config)#int f0/1

Router(config-if)#ip add 61.129.62.131 255.255.255.0

Router(config-if)#no sh

Router(config-if)#int f0/0

Router(config-if)#ip add 202.106.0.1 255.255.255.0

Router(config-if)#no sh

Pat和 静态nat 配置

做pat 让 vlan 10  vlan 20 网段的用户可以访问外网 外网地址映射到路由器外接口地址

router 1 路由器

Router(config)#access-list 1 permit 192.168.10.0 0.0.0.255

Router(config)#access-list 1 permit 192.168.20.0 0.0.0.255

Router(config)#

Router(config)#ip nat  inside source  list 1  int f0/0 overload

Router(config)#int f0/0

Router(config-if)#ip nat outside

Router(config-if)#int f0/1

Router(config-if)#ip nat inside

做静态nat 将 外部web  映射到 61.129.62.150  让外网终端可以访问内部的  "外部web"

router 1 路由器

Router(config-if)#ip nat inside source  static 172.16.0.200  61.129.62.150

Router(config)#int f1/0

Router(config-if)#ip nat inside

实验要求

扩展acl 列表

让vlan 10 和 vlan 20 用户能够访问ftp 但不能ping 通ftp

也不能访问内部web可以访问外部web

让管理区电脑可以访问所有 服务器 但不能访问ftp

Router 3 路由器

Router(config)#access-list 100 deny icmp 192.168.10.0 0.0.0.255 host 172.16.0.100 echo

Router(config)#access-list 100 deny icmp 192.168.20.0 0.0.0.255 host 172.16.0.100 echo

Router(config)#access-list 100 deny tcp  192.168.10.0 0.0.0.255 host 172.16.0.100 eq 80

Router(config)#access-list 100 deny tcp  192.168.20.0 0.0.0.255 host 172.16.0.100 eq 80

Router(config)#access-list 100 deny tcp  192.168.100.0 0.0.0.255 host 172.16.0.100 eq 21

Router(config)#access-list 100 permit ip  any any

Router(config)#int f1/0

Router(config-if)#ip acce

Router(config-if)#ip access-group 100 out

♥️关注,就是我创作的动力

♥️点赞,就是对我最大的认可

♥️这里是小刘,励志用心做好每一篇文章,谢谢大家