使用Psycopg2连接openGauss 3.0(python2)

发布于:2022-11-09 ⋅ 阅读:(9) ⋅ 点赞:(0) ⋅ 评论:(0)

书接上文《使用Psycopg2连接openGauss 3.0(python3)》
本文介绍基于 Python 2 如何编译安装 Psycopg2 。
测试环境仍然使用的是 麒麟 V10 SP2 操作系统,openGauss 3.0 数据库。

1 安装 postgresql-devel 、postgresql-libs 、postgresql 的 rpm 包

下载对应平台的安装包,上传安装。这里使用 --force --nodeps 选项强制安装即可。
这里主要为了解决 Psycopg2 在编译阶段的依赖问题。

rpm -ivh postgresql-devel-9.2.24-7.el7_9.x86_64.rpm --force --nodeps
rpm -ivh postgresql-libs-9.2.24-7.el7_9.x86_64.rpm --force --nodeps
rpm -ivh postgresql-9.2.24-7.el7_9.x86_64.rpm --force --nodeps

2 下载 Psycopg2 源码包

下载网址:https://pypi.org/project/psycopg2-binary/2.8.6/#files
将下载到的包上传到服务器。
在这里插入图片描述

3 解压并编译安装 Psycopg2 源码包

  • 解压 Psycopg2 源码包,并修改权限

tar -zxvf psycopg2-binary-2.8.6.tar.gz -C /usr/lib/python2.7/site-packages
mv /usr/lib/python2.7/site-packages/psycopg2-binary-2.8.6 /usr/lib/python2.7/site-packages/psycopg2
chmod 755 /usr/lib/python2.7/site-packages/psycopg2

在这里插入图片描述
在这里插入图片描述

  • 修改 setup.py 文件

cd /usr/lib/python2.7/site-packages/psycopg2
sed -i "s/(pgmajor, pgminor, pgpatch)/(9, 2, 4)/g" setup.py
  • 编译安装 Psycopg2

 python setup.py build
 python setup.py install

在这里插入图片描述
。。。在这里插入图片描述
在这里插入图片描述
。。。
在这里插入图片描述

4 验证 Psycopg2 安装成功

python
import psycopg2

在这里插入图片描述
此处执行 import psycopg2 没有报错即说明 Psycopg2 安装成功。
具体使用方面的验证可参见上一篇文章中的详细介绍《使用Psycopg2连接openGauss 3.0(python3)》