Android Studio Gradle插件版本与Gradle 版本对应关系

发布于:2023-01-20 ⋅ 阅读:(14) ⋅ 点赞:(0) ⋅ 评论:(0)

        工作中,新接手同事维护老项目,因升级 Android Gradle 插件版本与Gradle 版本不匹配,致使无法构建打包,特此进行了梳理。

目录

1、Android Gradle插件版本 与 Gradle版本关系

1.1、修改Gradle插件版本

1.2、修改Gradle版本

2、JDK版本 与 Gradle版本关系

3、Android Gradle插件版本 和 Android Studio版本兼容性


1、Android Gradle插件版本 与 Gradle版本关系

为了获得最佳性能,您应使用 Gradle 和插件这两者的最新版本。

插件版本 所需的 Gradle 版本
1.0.0 - 1.1.3 2.2.1 - 2.3
1.2.0 - 1.3.1 2.2.1 - 2.9
1.5.0 2.2.1 - 2.13
2.0.0 - 2.1.2 2.10 - 2.13
2.1.3 - 2.2.3 2.14.1 - 3.5
2.3.0+ 3.3+
3.0.0+ 4.1+
3.1.0+ 4.4+
3.2.0 - 3.2.1 4.6+
3.3.0 - 3.3.3 4.10.1+
3.4.0 - 3.4.3 5.1.1+
3.5.0 - 3.5.4 5.4.1+
3.6.0 - 3.6.4 5.6.4+
4.0.0+ 6.1.1+
4.1.0+ 6.5+
4.2.0+ 6.7.1+
7.0 7.0+
7.1 7.2+
7.2 7.3.3+

1.1、修改Gradle插件版本

打开《项目根目录/build.gradle》文件,写入所需要android gradle版本号。

建议:版本号不要使用动态依赖项,请写入具体的版本号,避免因自动升级致使的难以预料的错误。

1.2、修改Gradle版本

  • 在Android Studio的 File > Project Structure > Project 菜单中指定 Gradle 版本
  • 在文件《项目根目录/gradle/wrapper/gradle-wrapper.properties》指定版本号(如:7.4.2)
# Gradle配置文件《项目根目录/gradle/wrapper/gradle-wrapper.properties》指定版本号(如:7.4.2)
distributionUrl = "https\://services.gradle.org/distributions/gradle-7.4.2-all.zip"

Gradle Distributionshttps://services.gradle.org/distributions/

2、JDK版本 与 Gradle版本关系

要正常执行 Gradle 需要 JDK 8~18版本,目前尚不支持 Java 19 及更高版本。

Java 6 和 7 仍可用于编译和分叉测试执行

以下为Java版本与Gradle版本关系:

Java版本 第一个支持的Gradle版本
8 2.0
9 4.3
10 4.7
11 5.0
12 5.4
13 6.0
14 6.3
15 6.7
16 7.0
17 7.3
18 7.5

3、Android Gradle插件版本 和 Android Studio版本兼容性

Android Studio 构建系统以 Gradle 为基础,并且 Android Gradle 插件添加了几项专用于构建 Android 应用的功能。

以下为Android Studio 版本所需的 Android Gradle 插件版本关系:

Android Studio 版本 所需插件版本
Arctic Fox   | 2020.3.1 3.1-7.0
Bumblebee | 2021.1.1 3.2-7.1
Chipmunk   | 2021.2.1 3.2-7.2

如果您的项目不受某个特定版本的 Android Studio 支持,仍然可以使用旧版 Android Studio 打开和更新您的项目。

参考:Android Gradle 插件版本说明  |  Android 开发者  |  Android DevelopersAndroid Studio 构建系统以 Gradle 为基础,并且 Android Gradle 插件添加了几项专用于构建 Android 应用的功能。https://developer.android.google.cn/studio/releases/gradle-plugin.html#updating-plugin Compatibility Matrixicon-default.png?t=M666https://docs.gradle.org/current/userguide/compatibility.html#compatibility


网站公告

欢迎关注微信公众号

今日签到

点亮在社区的每一天
签到