网络实战之单臂路由与三层交换机配置

发布于:2022-11-09 ⋅ 阅读:(3) ⋅ 点赞:(0) ⋅ 评论:(0)

目录

一、单臂路由

1、单臂路由目的

2、单臂路由链路类型

3、单臂路由实验配置

①实验目的

②实验工具及机器

③实验拓扑

 ④实验步骤

 二、三层交换机

1、三层交换机作用

2、三层交换机实验配置

①实验目的

②实验工具及机器

③实验拓扑

 ④实验步骤

 三、总结


一、单臂路由

1、单臂路由目的

通过在路由器上划分出逻辑接口实现不通vlan之间直接通信。

2、单臂路由链路类型

①交换机与主机的端口为access链路。

②交换机与路由器之间端口为trunk链路,仅在单臂路由模式下。

3、单臂路由实验配置

①实验目的

  通过一个路由器实现人事部PC1与财务部PC2之间网络互通

②实验工具及机器

工具:eNSP V100R003C00SPC100虚拟器

路由器类型:华为AR2220路由器一台、华为S3700交换机一台、华为计算机二台。

③实验拓扑

 

 ④实验步骤

1、首先将pc1与pc2的ip地址与子网掩码网关配置完成。如下图:

 2、将pc1与pc2在交换机上分别划分到vlan 10 和vlan 20 中,并将G0/0/1端口配置为trunk口(特殊情况,仅在单臂路由情况下交换机与路由器连接使用trunk链路)代码如下。

<Huawei>undo terminal monitor    ##关闭用户视图提示
<Huawei>system-view              ##切换系统视图     
[Huawei]undo info-center enable  ##关闭系统视图提示
[Huawei]sysname SW1              ##更改交换机名字为SW1  
[SW1]vlan batch 10 20            ##创建vlan 10 vlan 20
[SW1]interface E0/0/1            ##进入E0/0/1端口  
[SW1-Ethernet0/0/1]port  link-type access  ##将E0/0/1端口类型配置为access 
[SW1-Ethernet0/0/1]port default vlan 10    ##将E0/0/1端口加入vlan 10
[SW1-Ethernet0/0/1]interface  E0/0/2       ##进入E0/0/2端口
[SW1-Ethernet0/0/2]port link-type access   ##将E0/0/2端口类型配置为access
[SW1-Ethernet0/0/2]port default vlan 20    ##将E0/0/2端口加入vlan 20
[SW1-GigabitEthernet0/0/2]quit             ##退出端口视图返回系统视图
[SW1]display  port vlan  active            ##查看端口vlan配置信息
[SW1] interface  G0/0/1                    ##进入G0/0/1端口
[LSW1-G0/0/1] port  link-type  trunk       ##配置G0/0/24端口类型为trunk口
[LSW1-G0/0/1] port  trunk  allow-pass    vlan all  ##trunk口放行所有vlan

图为查询端口vlan配置表,可以看到Ethernet0/0/1端口为vlan 10,Ethernet0/0/2端口为vlan 20。

 3、将路由器AR1划分出2个逻辑子接口g/0/0/0.10和g0/0/0.20,g/0/0/0.10配置ip地址为192.168.1.254 vlan为10,g/0/0/0.20配置ip地址为192.168.2.254  vlan为20。

<Huawei>undo terminal monitor    ##关闭用户视图提示
<Huawei>system-view              ##切换系统视图     
[Huawei]undo info-center enable  ##关闭系统视图提示
[Huawei]sysname AR1              ##更改路由器名字为AR1 
[AR1]interface  g0/0/0.10        ##创建g0/0/0.10 逻辑子接口
[AR1-GigabitEthernet0/0/0.10]dot1q termination vid 10 ##将此端口加入vlan 10 
[AR1-GigabitEthernet0/0/0.10]ip address 192.168.1.254 24 ##配置端口 ip地址
[AR1-GigabitEthernet0/0/0.10]arp broadcast enable        ## 打开ARP广播
[AR1-GigabitEthernet0/0/0.10]int g0/0/0.20         ##创建g0/0/0.20逻辑子接口
[AR1-GigabitEthernet0/0/0.20]dot1q termination vid 20  ##将此端口加入vlan 20
[AR1-GigabitEthernet0/0/0.20]ip address 192.168.2.254 24  ##配置端口 ip地址
[AR1-GigabitEthernet0/0/0.20]arp broadcast enable      ## 打开ARP广播
[AR1]display current-configuration                     ##查看当前路由器配置

图为查看当前路由器配置信息,回车键或者空格键可向下翻查看各个接口配置信息。如下图

 4、使用ping命令查看pc2是否可以ping通pc1,如下图已通,至此单臂路由实验结束。

 二、三层交换机

1、三层交换机作用

三层交换机是官方推荐的实现不通vlan之间通信的方式,三层交换机具有路由器的转发功能,内部有一张MLS表相当于路由表,与路由表不同的是三层交换机一次路由多次转发。

2、三层交换机实验配置

①实验目的

  通过三层交换机实现人事部PC1与财务部PC2之间网络互通

②实验工具及机器

工具:eNSP V100R003C00SPC100虚拟器

路由器类型:华为S5700三层交换机一台、华为S3700交换机一台、华为计算机二台。

③实验拓扑

 

 ④实验步骤

1、首先将PC1与PC2的IP地址、子网掩码、网关配置完成。如下图

2、在二层交换机SW1上将PC1与PC2的vlan划分完毕,PC1是vlan 10,PC2是vlan 20并将G0/0/1口配置为trunk口。

<LSW2>undo terminal  monitor            ##关闭用户视图提示信息
<LSW2>system-view                       ##进入系统视图
[Huawei]undo info-center enable           ##关闭系统视图配置
[Huawei]sysname SW1              ##更改交换机名字为SW1
[SW1]vlan batch 10  20                  ##创建vlan10 vlan 20
[SW1-E0/0/2]port link-type access        ##配置E0/0/2端口类型为access
[SW1-E0/0/2]port  default  vlan  10       ##将E0/0/2端口配置到vlan  10中
[SW1]interface   G0/0/3                    ##进入E0/0/3端口
[SW1-E0/0/3]port  link-type  access        ##配置E0/0/3端口类型为access
[SW1-E0/0/3]port  default  vlan  20         ##将E0/0/3端口配置到vlan 20中
[SW1-E0/0/3]interface  G0/0/1              ##进入G0/0/1端口 
[SW1-G0/0/1]port  link-type  trunk         ##将G0/0/1端口类型配置为trunk
[SW1-G0/0/1]port  trunk   allow-pass  vlan  all  ##trunk口放行所有vlan

3、在三层交换机SW1上配置vlanif 10 为192.168.1.254,vlanif 20 为192.168.2.254并将G0/0/1口配置为trunk口。

<LSW2>undo terminal  monitor            ##关闭用户视图提示信息
<LSW2>system-view                       ##进入系统视图
[Huawei]undo info-center enable           ##关闭系统视图配置
[Huawei]sysname SW2              ##更改交换机名字为SW2
[SW2]vlan batch 10  20                  ##创建vlan10 vlan 20
[SW2]int vlanif 10                      ##创建vlanif 10口
[SW2]ip address 192.168.1.254 24 ##为vlanif 10 配置ip地址
[SW2]int vlanif 20                      ##创建vlanif 20口
[SW2]ip address  192.168.2.254 24  ##为vlanif 20口配置ip地址
[SW2-G0/0/1]int G0/0/1                       ##进入G0/0/1口
[SW2-G0/0/1]port link-type trunk        ##将G0/0/1口配置为trunk口
[SW2-G0/0/1]port trunk allow-pass vlan  all  ##设置G0/0/1口放行所有vlan
[SW2-G0/0/1]quit                                 ##退回系统视图
[SW2] display current-configuration    ##查看当前交换机配置

图为查看当前交换机配置信息,回车键或者空格键可向下翻查看各个接口配置信息。如下图

 4、使用ping命令查看pc2是否可以ping通pc1,如下图已通,至此三层交换机配置实验结束。

 三、总结

三层交换机与单臂路由都是可以实现不通vlan之间的通信,但是路由器在实际生产中成本较高且官方更推荐使用三层交换机来实现vlan之间的通信,俩者各有优缺点,大家看情况使用。