1.实验拓扑
2.使用设备
eNSP模拟建议下行设备三台使用S3700模拟(全部使用S5700可能会出现流量丢失等异常问题。)
3.实验配置
[SW1]dis cu
#
sysname SW1
#
vlan batch 100 110
#
interface Ethernet0/0/1
port link-type access
port default vlan 100
#
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 100 110
stp disable
#
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 100 110
stp disable
#
smart-link group 1
restore enable
smart-link enable
port GigabitEthernet0/0/1 master
port GigabitEthernet0/0/2 slave
timer wtr 30
flush send control-vlan 110
#
[SW2]dis cu
#
sysname SW2
#
vlan batch 100 110
#
interface GigabitEthernet0/0/1
shutdown
port link-type trunk
port trunk allow-pass vlan 100 110
stp disable
smart-link flush receive control-vlan 110
#
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 100 110
stp disable
smart-link flush receive control-vlan 110
#
monitor-link group 1
port GigabitEthernet0/0/2 uplink
port GigabitEthernet0/0/1 downlink 1
timer recover-time 10
#
[SW3]dis cu
#
sysname SW3
#
vlan batch 100 110
#
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 100 110
stp disable
smart-link flush receive control-vlan 110
#
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 100 110
stp disable
smart-link flush receive control-vlan 110
#
monitor-link group 1
port GigabitEthernet0/0/1 uplink
port GigabitEthernet0/0/2 downlink 1
timer recover-time 10
#
[SW4]dis cu
#
sysname SW4
#
vlan batch 100 110
#
interface Vlanif100
ip address 192.168.100.254 255.255.255.0
#
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 100 110
stp disable
smart-link flush receive control-vlan 110
#
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 100 110
stp disable
smart-link flush receive control-vlan 110
#
4.实验现象
此处表示流量走向如下图所示
此时将SW2的上行链路关闭
[SW2-GigabitEthernet0/0/2]shutdown
此时流量走向